System Requirements














 

MONEY MANAGER GPS™

Money Manager GPS is certified for use only with Microsoft® Internet Explorer version 6.0 SP1 or 6.0 SP2 browsers. Please note: we are currently only providing limited support for Internet Explorer 7.0. For the best customer experience, we recommend using one of the certified browser versions listed as they have been tested and certified to work with the application.

Browsers must have 128-bit encryption. JavaScript and Cookies must be enabled, and you should have a local or network directory to store templates and files. If your browser does not meet the above standards, you will receive an error message and will NOT be allowed to access Money Manager GPS. You will be required to upgrade your browser to one of the certified versions listed above in order to log into Money Manager GPS.

If your browser exceeds the above standards, you will be allowed into Money Manager GPS. Typically, browser versions are upward compatible and should not cause any performance issues. However, the bank cannot guarantee that you will not experience any difficulties, as these versions have not been tested for use with Money Manager GPS.

Download Internet Explorer® 6.0 (SP1) from Microsoft®.

Recommended Minimum System Requirements

  • Operating System: Windows 95, 98, NT, 2000, XP
  • Memory: 256Mb Ram
  • Processor Speed: 233 Mhz
  • Screen Resolution: 800x600
  • High-Speed Internet Connection (DSL/Cable/T1): Strongly recommended for performance reasons
  • Local or Network Directory: Required to store templates, BAI files, ACH files, and PDF reports
  • Printer: Required for printing reports to hardcopy
  • Adobe® Reader® required to save or read reports saved in Adobe Acrobat format (PDF)
  • Adobe® Flash® Player® version 6.0 or higher. (Flash player is not required. However, if a version is present it must meet the requirement above.)
  • Adobe Reader
    If you do not have Adobe Reader:

    Download the latest version of Adobe Reader now.

    Get Adobe Flash Player

    Adobe Flash Player
    If you do not have Adobe Flash Player, one is not required. However, if you have a Flash Player installed, it must be version 6.0 or higher.

    Download the latest version of Adobe Flash Player now.

    Get Acrobat Reader

    Important Information for AOL Users
    We do not recommend using AOL. However, if you are using AOL, it must be at least version 8.0 and we recommend the following steps:
  • Launch AOL 8.0 and connect to the service
  • Minimize AOL after connecting
  • Go to Citizensbank.com and you'll be ready to register
  • Launch Microsoft Internet Explorer 6.0 SP1 or 6.0 SP2
  • Go to www.citizensbankmoneymanagergps.com and you will be ready to log in.

    Important Information for Macintosh Users
    Money Manager GPS is not certified for any browser of the Mac operating system. Your experience will not be that of a user of Internet Explorer. You may have the ability to log in and use certain functionality of the system; however, access into specific Money Manger GPS initiation products may not be successful. For this reason, we DO NOT recommend that you execute Money Manager GPS using a Mac-based platform.

    Important Information for Netscape Users
    Money Manager GPS is not certified for the Netscape browser. Your experience will not be that of a user of Internet Explorer. You may have the ability to log in and use certain functionality of the system; however, access into specific Money Manger GPS initiation products may not be successful. For this reason, we DO NOT recommend that you execute Money Manager GPS using a Netscape browser.

    Top Of Page


  • Member FDIC


    Citizens Money Manager GPS and the Citizens Logo are registered marks of Citizens Financial Group, Inc.
    © 2004 Citizens Financial Group, Inc. All rights reserved.
    Citizens Bank is a brand name of RBS Citizens, N.A. and Citizens Bank of Pennsylvania